$re = '/[1.-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}(\s+or\s+[1.-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}(?!\S))?/';
$str = '1 203 455 0742
1 203 265 9723
+1-203-826-7522
klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl
Fill out the form below, or call 1-800-541-0487
1 (203) 816 7500
1 203 816 7511
1-203-445-0000
1-208-687-4348 or 1-509-892-5779
1-208-687-4348 or 1-509-892-5779
Fill out the form below completely or call:
1-866-769-9533
All fields with (*) are required. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);