package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9_\-\\.]+)@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.)|(([a-zA-Z0-9\\-]+\\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\\]?)$`)
var str = `hitesh-bedre@\XX\XX\XX\XXX\
hitesh-bedre@XX\XXX\
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}