re = /^([a-zA-Z0-9_\-\\.]+)@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.)|(([a-zA-Z0-9\\-]+\\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\\]?)$/m
str = 'hitesh-bedre@\\XX\\XX\\XX\\XXX\\
hitesh-bedre@XX\\XXX\\
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end