package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\p{N}]`)
var str = `0123456789
0123456789
〇一二三四五六七八九十`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}