$re = '/[\p{N}]/m';
$str = '0123456789
0123456789
〇一二三四五六七八九十';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);