import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=明治|大正|昭和|平成)[二三四五六七八]?[一十]?[元一二三四五六七八九十〇](?=年)";
final String string = "平成元年\n"
+ "平成一年\n"
+ "平成十年\n"
+ "平成十年\n"
+ "平成一〇年\n"
+ "平成十一年\n"
+ "平成三十年\n"
+ "平成三〇年\n\n"
+ "大正十一年\n"
+ "明治十一年\n"
+ "昭和十一年";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}