use strict;
my $str = '平成元年
平成一年
平成十年
平成十年
平成一〇年
平成十一年
平成三十年
平成三〇年
大正十一年
明治十一年
昭和十一年';
my $regex = qr/(?<=明治|大正|昭和|平成)[二三四五六七八]?[一十]?[ 元一二三四五六七八九十〇](?=年)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}