const regex = /-{3}.*[\s\S]*?(?=\s*(?:-{3}|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-{3}.*[\\s\\S]*?(?=\\s*(?:-{3}|$))', 'g')
const str = `---Agent 1: Wednesday 08/16/2017 | 11:43 AM ---
Message 1
--- Agent 1: Friday 06/09/2017 | 9:02 AM ---
Message 2
--- Agent 1: Friday 04/14/2017 | 10:35 AM ---
Message 3
--- Agent 1: Monday 02/13/2017 | 12:07 AM ---
This
is
message
3
--- Agent 1: Monday 12/19/2016 | 1:31 PM ---
Message 4
--- Agent 1: Monday 10/24/2016 | 10:48 AM ---
Message 5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}