import Foundation
let pattern = #"-{3}.*[\s\S]*?(?=\s*(?:-{3}|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
---Agent 1: Wednesday 08/16/2017 | 11:43 AM ---
Message 1
--- Agent 1: Friday 06/09/2017 | 9:02 AM ---
Message 2
--- Agent 1: Friday 04/14/2017 | 10:35 AM ---
Message 3
--- Agent 1: Monday 02/13/2017 | 12:07 AM ---
This
is
message
3
--- Agent 1: Monday 12/19/2016 | 1:31 PM ---
Message 4
--- Agent 1: Monday 10/24/2016 | 10:48 AM ---
Message 5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)