package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z.!#$%&'+/=?^_`{|}~-][a-zA-Z0-9.!#$%&'+/=?^_`{|}~-]*@
`)
var str = `a@
1@
b123@
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}