const regex = /href=(['"])(?:.*\/wp-content\/uploads\/2018\/01\/(?:(?:.*( ))+?).*\.(?:pdf|doc|docx))\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=([\'"])(?:.*\\\/wp-content\\\/uploads\\\/2018\\\/01\\\/(?:(?:.*( ))+?).*\\.(?:pdf|doc|docx))\\1', 'g')
const str = `<a href="/wp-content/uploads/2017/09/Some%20FileName%20That%20Wasnt%20sanitized%20at_all986.pdf">
<a title="Some title of the linked document" href="https://[redacted]/wp-content/uploads/2018/01/Some Title Thats Not Sanitized And Has Spaces 1.1.111-id1111.pdf" target="_blank" rel="noopener">Some Link Text For This</a></li>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}