import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"href=(['"])(?:.*\/wp-content\/uploads\/2018\/01\/(?:(?:.*( ))+?).*\.(?:pdf|doc|docx))\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="/wp-content/uploads/2017/09/Some%20FileName%20That%20Wasnt%20sanitized%20at_all986.pdf">
<a title="Some title of the linked document" href="https://[redacted]/wp-content/uploads/2018/01/Some Title Thats Not Sanitized And Has Spaces 1.1.111-id1111.pdf" target="_blank" rel="noopener">Some Link Text For This</a></li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)