const regex = /(?<=<a href=\"[^"]*)-(?=[^&"]*\.html\">)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<a href=\\"[^"]*)-(?=[^&"]*\\.html\\">)', 'gm')
const str = `<div id="breadcrumb-section">
<ol id="breadcrumbs">
<li class="first">
<span>
<a href="index.html">Technologies</a>
</span>
</li>
<li>
<span>
<a href="Some-Technologies-Documentation_218464400.html">Some Technologies Documentation</a>
</span>
</li>
<li>
<span>
<a href="Some-Other-Documentation_268370090.html">Some Other Documentation</a>
</span>
</li>
<li>
<span>
<a href="Another-Documentation_268370112.html">Another Documentation</a>
</span>
</li>
</ol>
</div>`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);