import Foundation
let pattern = #"(?<=<a href=\"[^"]*)-(?=[^&"]*\.html\">)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div id="breadcrumb-section">
<ol id="breadcrumbs">
<li class="first">
<span>
<a href="index.html">Technologies</a>
</span>
</li>
<li>
<span>
<a href="Some-Technologies-Documentation_218464400.html">Some Technologies Documentation</a>
</span>
</li>
<li>
<span>
<a href="Some-Other-Documentation_268370090.html">Some Other Documentation</a>
</span>
</li>
<li>
<span>
<a href="Another-Documentation_268370112.html">Another Documentation</a>
</span>
</li>
</ol>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)