package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a(?:x{7,8})?b`)
var str = `abaxbaxxxxxxbaxxxxxxxbaxxxxxxxxbaxxxxxxxxxxb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}