package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+@\S+\.\S+|(\w+\.\w+)`)
var str = `a.a b.b:c.c d.d@e.e.e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}