$re = '/\S+@\S+\.\S+|(\w+\.\w+)/';
$str = 'a.a b.b:c.c d.d@e.e.e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);