#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:chara":|motion":)\K([^,\n]*)|(?:null,)\K(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))"
Local $sString = "},null,"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」","「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」"],["player",null,"「利用……?」",null,64,{" & @CRLF & _
" "data": [["bg","stage",{" & @CRLF & _
" "action": [["zpos",233.33333333333337]]," & @CRLF & _
" "class": "stage"," & @CRLF & _
" "name": "bg"," & @CRLF & _
" "redraw": {" & @CRLF & _
" "disp": 2," & @CRLF & _
" "imageFile": {" & @CRLF & _
" "file": "bg03.mtn"," & @CRLF & _
" "options": {" & @CRLF & _
" "chara": "背景"," & @CRLF & _
" "motion": "昼"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")