import Foundation
let pattern = #"(?:chara":|motion":)\K([^,\n]*)|(?:null,)\K(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
},null,"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」","「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」"],["player",null,"「利用……?」",null,64,{
"data": [["bg","stage",{
"action": [["zpos",233.33333333333337]],
"class": "stage",
"name": "bg",
"redraw": {
"disp": 2,
"imageFile": {
"file": "bg03.mtn",
"options": {
"chara": "背景",
"motion": "昼"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)