#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\%(?<customer>[A-Z][a-z]+)\%[^|$%.]*?<(?<product>\w+)>[^|$%.]*?\|(?<count>\d+)\|[^|$%.]*?(?<price>\d+\.?\d*)\$$"
Local $sString = "%George%<Croissant>|2|10.3$" & @CRLF & _
"%Peter%<Gum>|1|1.3$" & @CRLF & _
"%Maria%<Cola>|1|2.4$" & @CRLF & _
"%InvalidName%<Croissant>|2|10.3$" & @CRLF & _
"%Peter%<Gum>1.3$" & @CRLF & _
"%Maria%<Cola>|1|2.4" & @CRLF & _
"%Valid%<Valid>valid|10|valid20$" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")