const regex = /^\%(?<customer>[A-Z][a-z]+)\%[^|$%.]*?<(?<product>\w+)>[^|$%.]*?\|(?<count>\d+)\|[^|$%.]*?(?<price>\d+\.?\d*)\$$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\%(?<customer>[A-Z][a-z]+)\\%[^|$%.]*?<(?<product>\\w+)>[^|$%.]*?\\|(?<count>\\d+)\\|[^|$%.]*?(?<price>\\d+\\.?\\d*)\\$$', 'gm')
const str = `%George%<Croissant>|2|10.3\$
%Peter%<Gum>|1|1.3\$
%Maria%<Cola>|1|2.4\$
%InvalidName%<Croissant>|2|10.3\$
%Peter%<Gum>1.3\$
%Maria%<Cola>|1|2.4
%Valid%<Valid>valid|10|valid20\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}