$re = '/\b(?=\w*(\w{2})(?:\w*\1){2})\w+/m';
$str = 'contentment and maintaining are such words';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);