re = /\b(?=\w*(\w{2})(?:\w*\1){2})\w+/m
str = 'contentment and maintaining are such words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end