package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\s].*?(?:%(?:%%)*))([0-9.]*)([lhjztL]*)([cCdiouxXeEfgGaAnpsSZRr])`)
var str = `arg1 %%%22lld arg2 %22lld`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}