re = /([^\s].*?(?:%(?:%%)*))([0-9.]*)([lhjztL]*)([cCdiouxXeEfgGaAnpsSZRr])/
str = 'arg1 %%%22lld arg2 %22lld'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end