$re = '/^(?!.*?(?:\/api\/)).*$/m';
$str = 'https://localhost.com/api/images/1/file
https://localhost.com/
https://localhost.com/about';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);