re = /^(?!.*?(?:\/api\/)).*$/m
str = 'https://localhost.com/api/images/1/file
https://localhost.com/
https://localhost.com/about'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end