$re = '/<script>(.*?)<\/script>/ms';
$str = '<script>
if
</script>
текст
<script>
if
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);