re = /<script>(.*?)<\/script>/m
str = '<script>
if
</script>
текст
<script>
if
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end