package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\S*\s*<artifactID>nginx-node<\/artifactID>\s*\S*\s*$`)
var str = ` <groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.0</version>
<groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.1</version>
<groupID>com.test</groupID>
<artifactID>nginx</artifactID>
<verion>1.2</version>
<groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.0</version>
<groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.1</version>
<groupID>com.test</groupID>
<artifactID>nginx</artifactID>
<verion>1.2</version>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}