// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((1558[0-9]{6})|(310[0-9]{9}))$").unwrap();
let string = "1558218374
1559218374
1234567899
2155817896
310123456789
311123456789
131023456789
123456789999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}