package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?\\\\)(\[.+\])(.+)`)
var str = `Lorem \[ipsum\] \\[dolor] sit amet`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}