$re = '/(.+?\\\\\\\\)(\[.+\])(.+)/m';
$str = 'Lorem \\[ipsum\\] \\\\[dolor] sit amet';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;