#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxs)^\QJob started\E" & @CRLF & _
"(?:(?!\QJob ended\E).)+?" & @CRLF & _
"^\QJob executed successfully\E"
Local $sString = "Job started at '0902 23:56:00:367' orderno - '0tzh0' runno - '00064' Number of transfers - 1" & @CRLF & _
"" & @CRLF & _
"Host1 'Local'[Windows-LOCAL] username 'xxx\xxx' - Host2 'xxx.xxx.xx'[Unix-SFTP] username 'xxx'" & @CRLF & _
"" & @CRLF & _
"Local host is: xxx - Windows 200x [601] Service Pack 1 build 7601 - Intel64 Family 6 Model 37 Stepping 1, GenuineIntel" & @CRLF & _
"" & @CRLF & _
"********** Starting transfer #1 out of 1 *************** Transfer #1 completed successfully" & @CRLF & _
"" & @CRLF & _
"Job executed successfully. exiting." & @CRLF & _
"" & @CRLF & _
"Job ended at '0902 23:56:07:138' Elapsed time [7sec] CPU usage [0.15sec]" & @CRLF & _
"" & @CRLF & _
"Job started at '0831 15:26:00:365' orderno - '0tuq5' runno - '00030' Number of transfers - 4" & @CRLF & _
"" & @CRLF & _
"Host1 'Local'[Windows-LOCAL] username 'xxx\xxx' - Host2 'xxx.xxx.xx'[Unix-SFTP] username 'xxx'" & @CRLF & _
"" & @CRLF & _
"Local host is: xxx - Windows 200x [601] Service Pack 1 build 7601 - Intel64 Family 6 Model 37 Stepping 1, GenuineIntel" & @CRLF & _
"" & @CRLF & _
"********** Starting transfer #1 out of 4 *************** Unable to connect to SSH server on 'xxx.xxx.xx': SFTP_Connect : psftp_connect failed : ssh_init: Network error: Connection timed out ." & @CRLF & _
"" & @CRLF & _
"Connection to host sftp.onenet.be could not be established" & @CRLF & _
"" & @CRLF & _
"Job ended at '0831 15:26:21:426'" & @CRLF & _
"" & @CRLF & _
"Elapsed time [21sec] CPU usage [0.0sec]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")