import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\QJob started\\E\n"
+ "(?:(?!\\QJob ended\\E).)+?\n"
+ "^\\QJob executed successfully\\E";
final String string = "Job started at '0902 23:56:00:367' orderno - '0tzh0' runno - '00064' Number of transfers - 1\n\n"
+ "Host1 'Local'[Windows-LOCAL] username 'xxx\\xxx' - Host2 'xxx.xxx.xx'[Unix-SFTP] username 'xxx'\n\n"
+ "Local host is: xxx - Windows 200x [601] Service Pack 1 build 7601 - Intel64 Family 6 Model 37 Stepping 1, GenuineIntel\n\n"
+ "********** Starting transfer #1 out of 1 *************** Transfer #1 completed successfully\n\n"
+ "Job executed successfully. exiting.\n\n"
+ "Job ended at '0902 23:56:07:138' Elapsed time [7sec] CPU usage [0.15sec]\n\n"
+ "Job started at '0831 15:26:00:365' orderno - '0tuq5' runno - '00030' Number of transfers - 4\n\n"
+ "Host1 'Local'[Windows-LOCAL] username 'xxx\\xxx' - Host2 'xxx.xxx.xx'[Unix-SFTP] username 'xxx'\n\n"
+ "Local host is: xxx - Windows 200x [601] Service Pack 1 build 7601 - Intel64 Family 6 Model 37 Stepping 1, GenuineIntel\n\n"
+ "********** Starting transfer #1 out of 4 *************** Unable to connect to SSH server on 'xxx.xxx.xx': SFTP_Connect : psftp_connect failed : ssh_init: Network error: Connection timed out .\n\n"
+ "Connection to host sftp.onenet.be could not be established\n\n"
+ "Job ended at '0831 15:26:21:426'\n\n"
+ "Elapsed time [21sec] CPU usage [0.0sec]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}