$re = '/(\d+)ab/';
$str = '1ab 2cd 3se 4ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);