$re = '/^\w+(.\w+)*@[a-zA-Z0-9-]+?\.[a-zA-Z]{2,3}$ /m';
$str = 'mail@company.ae.com
mail@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);