re = /^\w+(.\w+)*@[a-zA-Z0-9-]+?\.[a-zA-Z]{2,3}$ /m
str = 'mail@company.ae.com
mail@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end