package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^This is a sequence (.*?)(?:\. |$)`)
var str = `This is a sequence of nothing. This is another`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}