re = /^This is a sequence (.*?)(?:\. |$)/m
str = 'This is a sequence of nothing. This is another'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end