using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^|\.\ )\b[A-Z][a-z]+(?:\ [A-Z][a-z]+)*\b";
string input = @"This is a Sample Sentence to check the Real Value of this code. Whether it works or Not depends upon the Final Result.
UK Parliament
Hi, Bob
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}