$re = '/(?<!^|\.\ )\b[A-Z][a-z]+(?:\ [A-Z][a-z]+)*\b/m';
$str = 'This is a Sample Sentence to check the Real Value of this code. Whether it works or Not depends upon the Final Result.
UK Parliament
Hi, Bob
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);