import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*Disconnected from (invalid |authenticating )?user .* [^ ]+ port [0-9]+( \\[preauth\\])?$";
final String string = "Jan 17 08:49:00 thesquareplanet.com sshd[2744]: Disconnected from invalid user wp-user 89.134.42.194 port 38866 [preauth]\n\n"
+ "Jan 17 03:13:00 thesquareplanet.com sshd[2631]: Disconnected from invalid user Disconnected from 46.97.239.16 port 55920 [preauth]\n\n"
+ "Jan 17 10:00:29 thesquareplanet.com sshd[2775]: Disconnected from user jon 18.26.4.53 port 39872";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}