$re = '/=.+?\(/m';
$str = 'y:=select(R,(time>50)and(qty<10))';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;