import re
regex = re.compile(r"\b(?<!\d[.,])\d+(?:[.,]0+)?\b(?![,.]\d)", flags=re.MULTILINE)
test_str = ("Test (2.00001) Test (2.000) Test 2.1 Test (2,0001) Test 2,000 Test 2,1000 test 2\n\n"
"test 2 2.00\n"
"234566")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")