re = /\b(?<!\d[.,])\d+(?:[.,]0+)?\b(?![,.]\d)/m
str = 'Test (2.00001) Test (2.000) Test 2.1 Test (2,0001) Test 2,000 Test 2,1000 test 2
test 2 2.00
234566'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end