$re = '/(?x)^(?P<crt>crt)
(?:
(?:
(?:_) (?P<sm>start_mode)(?P<ul>_)?(?P<smq>(?(ul)normal|ep))
| (?:
(?P<bool>[01])\B
(?:_
(?:
(?: (?P<dual>dual(?P<dq>ch))
| (?P<ext>extended)(?P<q>ch|da|ep)
| (?P<std>standard)
| (?P<bstr>\w*)) ) | )
| (?: (?: (?P<digit>[2-9])(?:_)(?P<str>\w*))) )
)
)$/m';
$str = 'crt_start_mode_normal
crt_start_modeep
crt0_dualch
crt0_abc
crt1_xyzzy
crt2_abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);