package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([ ]*[-+]?[ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\*[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))([ ]*[+-][ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\*[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))[ ]*)+[ ]*)+)|([ ]*[-+]?[ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\*[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))[ ]*)`)
var str = `判断多项式是不是合法
题目文档:
https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf
1-2*x^-2+5*x^12-4*x+12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}