const regex = /(([ ]*[-+]?[ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\*[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))([ ]*[+-][ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\*[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))[ ]*)+[ ]*)+)|([ ]*[-+]?[ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\*[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))[ ]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([ ]*[-+]?[ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))([ ]*[+-][ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))[ ]*)+[ ]*)+)|([ ]*[-+]?[ ]*([ ]*([+-]?[ ]*(([1-9]([ ]*[0-9]*)*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*))[ ]*)', 'gm')
const str = `判断多项式是不是合法
题目文档:
https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf
1-2*x^-2+5*x^12-4*x+12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}