import re
regex = re.compile(r"([+-]?(?:(?:\d+\.?\d*\*?[xX]\^\d+)|(?:\d+\.?\d*\*?[xX])|(?:[xX]\^\d+)|(?:[xX])|(?:\d+\.?\d*)))")
test_str = ("-5.0x^5 + 20x^4 +x^3 + x +2\n"
"5*x^4 + 2.5*x + 3")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)